Change Background

Kamis, 11 April 2013

Web Developer

Web developer adalah seorang yang menciptakan aplikasi berbasis web dengan menggunakan bahasa pemrograman, pada dasarnya, web developer adalah sebagai penghubung dari sumber daya yang akan digunakan pada sebuah website, mulau dari pemanggilan database, membuat halaman website yang dinamis, hingga mengatur pengunjung untuk berinteraksi dengan elemen-elemen website tersebut.

contoh hasil dari seorang web developer adalah website website yang sehari-hari kita lihat seperti facebook, twitter, kaskus dan lain-lain, seorang web developer sangat erat dengan programer dan design, dengan berkerja sama mereka akan membuat hasil sebuah website yang sangat bagus, rapih, dan enak untuk dilihat.


Dalam membuat Web, seorang desainer Web menentukan aspek-aspek desain yang diperlukan seperti pemilihan Font, warna, tataletak, dan lainnya. Tugas seorang desainer Web tidaklah semudah yang dibayangkan, penguasaan software-software grafis dan animasi dan HTML authoring saja tidak cukup untuk membuat situs Web yang baik. Banyak hal yang harus menjadi pertimbangan, terlebih bila dihadapkan dengan keinginan Klien, kita akan dihadapkan dengan kepuasan klien. Terkadang idealisme kita sebagai desainer Web akan kalah dengan idealisme klien.

Dengan berkembangnya spesialisasi dalam desain komunikasi dan bidang teknologi informasi, ada kecenderungan kuat untuk menarik garis yang jelas antara desain web khusus untuk halaman web dan pengembangan web untuk logistik secara keseluruhan dari semua layanan berbasis web.


Source :http://parkshinheru.blogspot.com/2012/12/web-design.html
                http://www.balinter.net/news_89_Web_Developer.html

Nama : Fajar Romadhoni
Kelas : 2IA24

Sejarah dan Pengertian HTTP

Pengertian HTTP (HyperText Transfer Protocol) adalah protokol yang dipergunakan untuk mentransfer dokumen dalam World Wide Web (WWW atau sebuah protokol meminta/menjawab antara client dan server, maksudnya adalah data dokumen dikirim sesuai dengan isi dari dokumen tersebut tanpa memandang tipe dari dokumen.

Protokol HTTP pertama kali dipergunakan dalam WWW pada tahun 1990. Pada saat tersebut yang dipakai adalah protokol HTTP versi 0.9. Versi 0.9, pada tahun 1996 protokol HTTP diperbaiki menjadi HTTP versi 1.0. Perubahan ini untuk mengakomodasi tipe-tipe dokumen yang hendak dikirim beserta enkoding yang dipergunakan dalam pengiriman data dokumen.Sesuai dengan perkembangan infrastruktur internet maka pada tahun 1999 dikeluarkan HTTP versi 1.1 untuk mengakomodasi proxy, cache dan koneksi yang persisten.HTTP sendiri juga digunakan sebagai protokol umum untuk komunikasi diantara berbagai user agent ( user agent adalah istilah yang digunakan untuk program yang dijalankan di sisi client, seperti web browser misalnya dalam konteks HTTP ) dan proxy/gateway dengan sistem internet lain seperti SMTP (Simple Mail Transfer Protocol – RFC 821 ), NNTP ( Network News Transfer Protocol – RFC 977 ), FTP ( File Transfer Protocol – RFC 959 ), Gopher ( RFC 1436 ) dan WAIS ( Wide Area Information Servers ). Dengan demikian, HTTP mengijinkan akses pada sumber daya yang tersedia pada aplikasi yang berbeda.

 Protokol yang digunakan untuk melayani fasilitas web/www ini mengunakan HTTP.Akhir-akhir  ini, hampir setiap lembaga mempunyai website yang digunakan sebagai sarana informasi yang up-to-date. Untuk dapat menghasilkan fasilitas tersebut, harus menyimpan dokumen web di web server agar dapat dibuka dari client.  Hal ini sering disebut dengan hosting, Untuk dapat membangun webserver dibutuhkan software sebagai web server, sofware ini sangat banyak sekali namun untuk platform Linux, web server yang terkenal handal adalah Apache.

Source : http://vadzindo.blog.com/2011/01/25/sejarah-dan-pengertian-http/


Nama : Fajar Romadhoni
NPM : 52411646

Menghapus Daftar Startup

aplikasi yang muncul saat laptop atau pc baru dinyalakan seperti yahoo messengger atau aplikasi lainnya dapat mengganggu atau memperlambat start up laptop atau pc anda, menghilangkan beberapa aplikasi start up dapat membuat booting laptop atau pc anda sedikit lebih cepat, berikut ini adalah caranya
Klik Start >> Run >> kemudian ketik msconfig lalu ENTER. 

Di sana banyak daftar program atau aplikasi yang berjalan secara otomatis saat komputer dijalankan dan ini dapat menyebabkan proses booting menjadi berat atau lambat.

                                                          

Nah, jika kita sudah menghapusnya dari system namun masih muncul dalam daftar startup, kita dapat menghapusnya secara permanen daftar startup msconfig dari system, dengan langkah sebagai berikut.

1. Klik Start >> Run >> kemudian ketik regedit kemudian OK atau ENTER.
2. Klik HEY_LOCAL_MACHINE >> SOFTWARE >> Microsoft >> Shared Tool >> Msconfig >> Startupreg
3. Kemudian hapus aplikasi-aplikasi yang sudah dihapus dari system satu persatu, dengan cara klik kanan pada aplikasi yang dimaksud kemudian pilih delete.

                                                           

4. Jika sudah, kemudian tutup registry
5. Restart Komputer
6. Selesai


jika saat anda Klik Start >> Run >> kemudian ketik msconfig lalu ENTER. muncul seperti gambar di bawah


jangan kecewa, langsung search saja system-nya dengan Klik Start >> lalu ketikan System Configuration lalu lanjutkan seperti langkah di atas

Selasa, 19 Maret 2013

Tugas Pengantar Web Science : Arsitektur Website


Arsitektur Website adalah suatu pendekatan terhadap desain dan perencanaan situs yang, seperti arsitektur itu sendiri, melibatkan teknis, kriteria estetis dan fungsional. Seperti dalam arsitektur tradisional, fokusnya adalah benar pada pengguna dan kebutuhan pengguna. Hal ini memerlukan perhatian khusus pada konten web, rencana bisnis, kegunaan, desain interaksi, informasi dan desain arsitektur web. Untuk optimasi mesin pencari yang efektif perlu memiliki apresiasi tentang bagaimana sebuah situs Web terkait dengan World Wide Web.
Sejak web perencanaan isi, desain dan manajemen datang dalam lingkup metode desain, Vitruvian tradisional tujuan komoditas, keteguhan dan kesenangan dapat memandu arsitektur situs, seperti yang mereka lakukan arsitektur fisik dan disiplin desain lainnya. Website arsitektur akan datang dalam ruang lingkup estetika dan teori kritis dan kecenderungan ini dapat mempercepat dengan munculnya web semantik dan web 2.0. Kedua ide menekankan aspek struktur informasi. Strukturalisme adalah sebuah pendekatan untuk pengetahuan yang telah dipengaruhi sejumlah disiplin akademis termasuk estetika, teori kritis dan postmodernisme. Web 2.0, karena melibatkan user-generated content, mengarahkan perhatian arsitek website untuk aspek-aspek struktur informasi.
1. Halaman Depan (Home Page)
Setiap website memiliki halaman depan. Pada umumnya, halaman depan merupakan halaman pertama yang dilihat oleh pengunjung dan juga merupakan halaman yang paling penting dalam mendapatkan urutan pencarian yang tinggi dari mesin pencari
2 . Halaman Produk/Jasa
Bagian utama dari website berisi penawaran produk dan/atau jasa
3. Halaman Informasi
Halaman informasi merupakan halaman-halaman yang memberikan informasi kepada pengunjung selain informasi mengenai produk atau jasa. Halaman ini digunakan untuk membangun hubungan atau komunikasi sekaligus kepercayaan antara pengunjung dengan pemilik website.
4. Halaman Keanggotaan
Halaman keanggotaan merupakan bagian yang penting sekali untuk pengembangan website di masa mendatang.
5. Halaman Kontak
Halaman kontak berisi cara-cara untuk menghubungi pengurus website, bisa melalui email, telepon, fax, chatting, surat, ataupun dengan cara mengisi formulir pertanyaan atau komentar secara online.

Sumber:
http://edwinghofamz.wordpress.com/2011/04/07/arsitektur-website/

Nama: Fajar Romadhoni
NPM: 52411646

Tugas Pengantar Web Science : WWW


World Wide Web


WWW atau Word Wide Web merupakan kumpulan server web dari seluruh dunia yang mempunyai kegunaan untuk menyediakan data dan informasi untuk dapat digunakan bersama. WWW adalah bagian yang paling menarik dari Internet. Melalui web, para pengguna dapat mengakses informasi-informasi yang tidak hanya berupa teks tetapi bisa juga berupa gambar, suara, video dan animasi. 


Sejarah

WWW adalah suatu program yang ditemukan oleh Tim Berners-Lee pada tahun 1991. Awalnya Berners-Lee hanya ingin menemukan cara untuk menyusun arsip-arsip risetnya. Untuk itu, beliau mengembangkan suatu sistem untuk keperluan pribadi. Sistem itu adalah program peranti lunak yang diberi nama Enquire. Dengan program itu, Berners-Lee berhasil menciptakanjaringan yang menautkan berbagai arsip sehingga memudahkan pencarian informasi yang dibutuhkan. Inilah yang kelak menjadi dasar dari sebuah perkembangan pesat yang dikenal sebagai WWW.

Halaman Web adalah halaman yang tampak dari sebuah software web browser. Halaman ini seperti file dokumen word-processing, kecuali didalamnya dapat terkandung text, gambar bahkan animasi. Untuk dapat membuat halaman web ini anda harus memiliki pengetahuan tentang skrip (script) HTML (hyper-text markup language). 

Situs Web terdiri dari beberapa halaman web yang saling terkait (linked) antara yang satu dengan yang lain dengan satu cara tertentu. Kebanyakan orang masih rancu dengan definisi ini sehingga mempersulit pemahaman selanjutnya.


Sumber : 
http://id.wikipedia.org/wiki/World_Wide_Web
Kristianto Dwi,ST, 2002, http://faculty.petra.ac.id/dwikris/docs/desgrafisweb/www/4-apaitu_www.html

Nama : Fajar Romadhoni
NPM : 52411646

Kamis, 24 Januari 2013

Tugas 3 PTI & New Media : HTML5


HTML5 adalah sebuah bahasa markah untuk menstrukturkan dan menampilkan isi dari Waring Wera Wanua, sebuah teknologi inti dari Internet. HTML5 adalah revisi kelima dari HTML (yang pertama kali diciptakan pada tahun 1990 dan versi keempatnya, HTML4, pada tahun 1997) dan hingga bulan Juni 2011 masih dalam pengembangan. Tujuan utama pengembangan HTML5 adalah untuk memperbaiki teknologi HTML agar mendukung teknologi multimedia terbaru, mudah dibaca oleh manusia dan juga mudah dimengerti oleh mesin.
HTML5 merupakan salah satu karya Konsortium Waring Wera Wanua (World Wide Web Consortium, W3C) untuk mendefinisikan sebuah bahasa markah tunggal yang dapat ditulis dengan cara HTML ataupun XHTML. HTML5 merupakan jawaban atas pengembangan HTML 4.01 dan XHTML 1.1 yang selama ini berjalan terpisah, dan diimplementasikan secara berbeda-beda oleh banyak perangkat lunak pembuat web.
WHATWG bekerja dengan bentuk web dan aplikasi dan W3C merupakan pengembang dari XHTML 2.0 pada tahun 2006, kemudian mereka memutuskan untuk bekerja sama dan membentuk versi baru dari HTML.

Berikut tujuan dibuatnya HTML5 :

  • Fitur baru harus didasarkan pada HTML, CSS, DOM, dan JavaScript
  • Mengurangi kebutuhan untuk plugin eksternal ( Seperti Flash )
  • Penanagan kesalahan yang lebih baik
  • Lebih markup untuk menggantikan scripting
  • HTML5 merupakan perangkat mandiri
  • Proses pembangunan dapat terlihat untuk umum

Fitur baru dalam HTML5 :

  • Unsur kanvas untuk menggambar
  • Video dan elemen audio untuk media pemutaran
  • Dukungan yang lebih baik untuk penyimpanan secara offline
  • Elemen konten yang lebih spesifik, seperti artikel, footer, header, nav, section
  • Bentuk kontrol form seperti kalender, tanggal, waktu, email, url, search.


Tugas 3 PTI & New Media : CMS


Sistem manajemen konten (content management System, disingkat CMS), adalah perangkat lunak yang memungkinkan seseorang untuk menambahkan dan/atau memanipulasi (mengubah) isi dari suatu situs Web. Umumnya, sebuah CMS (Content Management System) terdiri dari dua elemen:
  • aplikasi manajemen isi (Content Management Application, [CMA])
  • aplikasi pengiriman isi (content delivery application [CDA]).
Elemen CMA memungkinkan pengelola konten -yang mungkin tidak memiliki pengetahuan mengenai HTML (Protokol Transfer Hiperteks)-, untuk mengelola pembuatan, pengubahan, dan penghapusan isi dari suatu situs web tanpa perlu memiliki keahlian sebagai seorang webmaster. Elemen CDA menggunakan dan menghimpun informasi-informasi yang sebelumnya telah ditambah, dikurangi atau diubah oleh pemilik situs web untuk memperbaharui situs web tersebut. Kemampuan atau fitur dari sebuah sistem CMS berbeda-beda. Walaupun begitu, kebanyakan dari perangkat lunak ini memiliki fitur publikasi berbasis Web, manajemen format, kontrol revisi, pembuatan indeks, pencarian, dan pengarsipan.

Manfaat CMS
1.    Manajemen data
2.    Mengatur siklus hidup website
3.    Mendukung web templating dan standarisasi
4.    Personalisasi website
5.    Sindikasi
 Pemanfaatan CMS
CMS pada prinsipnya dapat dipergunakan untuk berbagai macam keperluan dan dalam berbagai kondisi, seperti untuk:
1.    Mengelola website pribadi.
2.    Mengelola website perusahaan/bisnis.
3.    Portal atau website komunitas.
4.    Galeri foto, dan lain sebagainya.
5.    Forum.
6.    Aplikasi E-Commerce.
7.    Dan lain-lain
 Dan juga Content Manajement System didefenisikan sebagai Sebuah System yang memberikan kemudahan kepada penggunanya dalam mengelola dan mengadakan perubahan isi sebuah website dinamis tanpa tanpa sebelumnya dibekali pengetahuan tentang hal – hal yang bersifat teknis dalam sebuah mendesign sebuah website. Contoh CMS diantaranya WordPress,Joomla, Mambo, Drupal dll.